form validator

Mautic Form Validator Dialog Plugin

Gyors Megbízható Jól dokumentált Mautic bővítmény

Hosszú formokat használata esetén gyakran jelent problémát felhasználók számára hibásan kitöltött, vagy kitöltetlen mezők beazonosítása. Erre a problémára jelent kiváló megoldást a Form Validator Dialog bővítmény, ami lehetővé teszi, hogy a form-hibákat egy popup ablakban hozzuk a kitöltő tudtára.

verzió: 1.0.3

Milyen célt szolgál?

A Mautic gyári eszköztátárában lehetőség van a form beviteli mezőket validálni, azokhoz egyedi hibaüzeneteket rendelni. A hibaüzenetek alapértelmezetten a hibás, vagy kitöltetlen mezők mellett jelennek meg. Ez egy rövid form esetén kielégítő, hosszabb, görgethető form esetén azonban a hibásan kitöltött mező közelében megjelenő hibaüzenet elkerülheti a felhasználó figyelmét. 

A Validációs dialógusablak bővítmény azt teszi lehetővé, hogy a hibaüzeneteket egy modális ablakban jelenítsük meg a felhasználónak.

Hogyan működik?

Opcionális

A form összeállításakor eldönthető, hogy akarjuk-e használni, vagy sem.

Összegyűjtött hibaüzenetek megjelenítése

A form elküldése során lezajlik a form validálása. A mezők mellett megjelenítet hibaüzenetek mellett egy modális ablakban megjelenik a hibás, vagy kitöltetlen mezők listája a mezőhöz tartozó hibaüzenettel.

Témázható

A megjelenített modális ablak tartalmának megjelenése témából testre szabható.

Mire használható?

Hosszú formok

Nagyon hosszú formok esetén a hibásan kitöltött mezők mellett megjelenő hibaüzenet elkerülheti a kitöltő figyelmét. Ilyen esetben a felhasználó csak annyit érzékelhet, hogy hiába nyomkodja az elküld gombot, nem történik semmi. Ezen helyzet elkerülése érdekében érdemes a formba beépíteni egy a form ellenőrzésekor összegyűlt hibaüzeneteket megjelenítő dialogusablakot, ami egyértelművé teszi a felhasználó számára, hogy a form kitöltése hibás.

Nyomatékosítás

Elképzelhető, hogy egy form kitöltésénél különösen fel akarjuk hívni a felhasználó figyelmét a form kitöltésének hibáira.

Függőségek

A bővítmény használatához szükség van a phpbolt nevű php kiterjesztés futtatási környezetbe való beépítésére.
  • A kosár jelenleg üres.

Verziótörténet

1.0.3

  • Részletes dokumentáció

1.0.0

  • Első verzió